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Creating Section 508 Conformant PDFs
Notes:

e This document addresses the most common Section 508 checks and common Section 508 issues
encountered when remediating a PDF. This document may not cover all aspects of Section 508
and PDF remediation.

e This document provides one way, but not every way, to remediate a PDF for Section 508
conformance.

e Unless specified for a task, do not use the “Reading Order” tool found on the “Accessibility” tool,
or the “Order” or “Content” panes found on the “Navigation” pane, for tag order or logical
order. This document uses tags to confirm conformance with Section 508.

Working with a PDF

Discussed below are general common actions needed to remediate a PDF for Section 508 conformance.
This documentation is not a complete discussion on working with Adobe Acrobat. See
https://helpx.adobe.com/acrobat/user-guide.html for using Adobe Acrobat and find keyboard shortcuts
at https://helpx.adobe.com/acrobat/using/keyboard-shortcuts.html.

Navigation Pane Panes

The “Tags” pane found on the “Navigation” pane is used for the majority of remediation tasks covered in
this document. Other panes such as “Content” and “Order” are used for limited, specific tasks.
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Open a pane by selecting the “View” menu item, then select “Show/Hide,” then select “Navigation
Panes,” and then select the appropriate pane. The screen shot below shows these steps to select the
“Tags” pane in the “Navigation” pane.

™~

Navigation Pane

FHWA-HAD-21-001
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The screen shot below shows the “Tags” pane open. Each pane contains an “Options” dropdown as
highlighted below. Some remediation tasks are found in the “Options” dropdown.

Tools Pane

Options

Tags Pane

Adobe Acrobat contains a number of tools. To access these tools, go to the “View” menu item, then
select “Tools,” then select the tool to use.

Edit PDF Tool

Using the “Edit PDF” tool to edit content may corrupt the tag structure of surrounding content. Recheck

the tags after editing any content.

Working with Tags

This section provides general instructions for working with tags in a PDF.

FHWA-HAD-21-001
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Finding a Tag

To find the tag for specific content in a document, activate the “Selection Tool.” Typically, this is found
on the “Quick Tools” bar.

Selection Tool

FHWA-HAD-21-001 January 2021, Updated June 2024 4



Creating Section 508 Conformant PDFs

Highlight the content using the “Selection Tool” then select “Find Tag from Selection” from the
“Options” menu of the “Tags” pane as shown below. On selection of “Find Tag from Selection,” the
focus moves to the tag containing the highlighted content and the tag is expanded in the tag tree.
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Changing a Tag Label

If the tag label is not semantically correct, e.g., a “Paragraph” tag is a “Heading,” select the tag. Then go

Creating Section 508 Conformant PDFs

to the “Options” menu in the “Tags” pane and select “Properties.”

FHWA-HAD-21-001

Sthings.pdf - Adobe Acrobat Pro DC
File Edit View Plug-Ins Window Help

Home  Tools 5Sthings.pdf x
B ¥ 8 B Q

Tags X
(&

E-®

~ Tags

D © 4

Cut

G

Delete Tag
Delete Empty Tags

Reading Order (x)
Eind...
Copy Contents to Clipboard

Edit Class Map...
Edit Role Map...

Tag Annotations
v Document is Tagged PDF

v Apply Role Mapping to Tags
v Highlight Content

Properties...
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On the “Tag” tab, select the correct tag label type from the “Type” dropdown menu.

Object Properties n

Content Tag Color

Type: | Section ~
) Article A
Title! | Annotation

Biblicgraphy Entry
Actual Text: Block Quote
Caption

Code

Alternate Text: | Division

Document

Figure

Form v

1D:

Language: | v|

Edit Tag... Edit Attribute Objects... Edit Attribute Classes...

Close
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Inserting a Tag

To insert a tag, select “New Tag...” from the “Options” menu as shown below.
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In the “New Tag” dialog box, select the tag type to insert from the “Type” dropdown menu as shown
below.

Moving a Tag

Select the tag to move. Move the tag by dragging and dropping into the new location. Alternatively,
select “Cut” from the “Options” menu. Navigate to the tag before where the cut tag is to be pasted.
From the “Options” menu, select “Paste.” To nest the cut tag, select “Paste Child.”

Content in a Tag

To move content, expand the tag and navigate to the content. Follow the instructions above for
“Moving a Tag.”

Deleting a Tag

Select the tag to delete. From the “Options” menu select “Delete Tag.”

Tagged PDF

The first step to ensuring a PDF is Section 508 conformant is to confirm that the PDF is tagged. One way
to determine the logical structure of a PDF is through formatted headings and other visual cues.
However, some users cannot decipher the logical structure of a document using visual cues. “Tags” are
used to convey the document’s structure in a logical manner to those using assistive technology, e.g.,
the big bold font is a heading, the blue underlined text is a link, or the content is a list of four items. This
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logical structure of the tags is called a “Tag Tree.” Tags allow a proper reading of a document regardless
of how the content is accessed by the user.

Check for tags by opening the “Tags” pane in the “Navigation” pane.

.

Tag tree location

As shown above, in the “Tags” pane the location of the “Tag Tree” says “No Tags available.” This
document is not Section 508 conformant. The file needs tags to be remediated for accessibility. Always
create a tagged PDF from the source authoring tool.
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If the “Tags” pane shows “Tags” but the arrow “>” is not found to the left of “Tags” as shown below, the
document does not actually contain tags and is not Section 508 conformant.
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If the tag tree is expandable by selecting the “>” and contains tags, as shown below, continue checking
the document for Section 508 conformance following the procedures outlined in this document.
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From the “Tags” pane, select the “Options” menu. Confirm that the option “Document is Tagged PDF” is
checked on the dialog box as shown below. If not checked, select the phrase “Document is Tagged PDF”
to check.

References

e https://www.w3.org/TR/UNDERSTANDING-WCAG20/content-structure-separation-
programmatic.html.
e https://www.w3.org/TR/UNDERSTANDING-WCAG20/content-structure-separation-

sequence.html.

Document Properties
Document properties provide additional information about the document allowing users to quickly

access important information about the document, such as the title, author(s), keywords, and default
language. This information is also called “metadata.”
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Access the “Document Properties” dialog box in Adobe Acrobat by selecting the “File” menu item, then
select “Properties” as shown below.

g8 Edit View Plug-Ins Window Help

B Open... Ctrl+0O
Open Recent File »

E?} Create 2
Save As.. Shift+Ctrl+5
Save as Other »
Export To »

= print.. Ctrl+P

ﬁ Reduce File Size

Protect Using Password

[T share File
Properties... Ctrl+D
Close File Ctrl+W
Exit Application Ctrl+Q

Description
As shown below, select the “Description” tab and ensure the fields are completed as follows:

e Titleis correct and complete.
e Author is FHWA (Agency guideline).
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Inspect all the fields to confirm they do not contain references to any vendor or contractor (Agency
guideline).
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Security

After the information in the “Description” tab is entered and confirmed correct, select the “Security” tab
as shown below and ensure the following:

e “Content Copying for Accessibility” is allowed.

Document Properties X

Descriptio onts  Initial View Custom  Advanced

Document Security

The document's Security Method restricts what can be done to the document, To remove
security restrictions, set the Security Method to Mo Security.

Security Method: | No Security w Change Settings...

Can be Opened by All versions of Acrobat Show Details...

Document Restrictions Summary
Printing:  Allowed
Changing the Document:  Allowed
Document Assembly:  Allowed
Content Copying:  Allowed
Content Copying for Accessibility:  Allowed
Page Extraction:  Allowed
Commenting:  Allowed
Filling of form fields:  Allowed
Signing:  Allowed

Creation of Template Pages:  Allowed

Fonts
No adjustments are necessary for the “Fonts” tab.
Initial View

In the “Initial View” tab, ensure the file opens to the first page of the file by setting the “Open to page”
under “Layout and Magnification” to match the page label of the first page. If the first page of the file is
blank, which is typical for cover pages, leave the “Open to page” as blank. When selecting ok with the
“Open to page” as blank, and Adobe Acrobat gives the error message “The page number cannot be left
blank,” as shown below, put a space in the “Open to page” field. If “The page number cannot be left
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blank” error message continues after adding the space, set the page label “Style” to a style not used in
the document such as “a” then put “a” in the “Open to page” field.

Description Security Fonts  Imitial View  Custom  Advanced

Layout and Magnification

Navigation tab: | Page Only ~
Page |layout: | Single Page Continuous b
Magnification: |Defau|t o
Open to page: of 6(10)
Window Options

[ Resize window to inilte el =0 ta s 12

] Center window on sq _
\  The page number cannot be left blank.

O Open in Full Screen
Show: | Document Titl

User Interface Options

[ Hide menu bar
[J Hide tool bars

[ Hide window controls

Help oK Cancel

Next, ensure the document title instead of the file name is shown when opening the PDF by going to the

“Windows Options” section then select “Document Title” from the “Show” dropdown menu as shown
below.
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Leave all the other settings for “Layout and Magnification,” “Windows Options,” and “User Interface
Options” as their default setting.

Document Properties

Description  Security Fonts  Initial View  Custom  Advanced

Layout and Magnification

Navigation tab: | Page Only w
Page layout: | Single Page Continuous ~
Magnification: |Defau|t bl
Open to page: |1 of 1
Window Options

[[]Resize window to initial page
[ Center window on screen

[JOpen in Full Screen mode

Show: | File Name ~

File Mame

[IHide menu bar
[JHide toel bars

[ Hide window centrels

Custom

No adjustments are necessary for the “Custom” tab.
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Advanced

Select the “Advanced” tab and set the default language of the document to that matching the content
by going to the “Reading Options” section and select the appropriate language from the “Language”
dropdown menu as shown below.

Document Properties >

Description  Security  Fonts  Initial View  Custom

PDF Settings

Baze URL: |

Search Index: | Browse... Clear
Trapped: | Unknown w
Print Dialog Presets
Page 5caling: | Default ~

DuplexMode: | Simplex o
Paper Source by Page Size:  []

Print Page Range:

Mumber of Copies: | Default

Reading Opticns

Binding: | Left Edge w

Language: |English W

If the document contains content in more than one language, set the default to that of the language for
the majority of the content and manually set the language for the specific content using the instructions
in the Language of Parts section in this document.

References

e https://www.w3.org/TR/WCAG20-TECHS/PDF16.html.
e https://www.w3.org/TR/WCAG20-TECHS/PDF18.html.
e https://www.w3.org/TR/UNDERSTANDING-WCAG20/navigation-mechanisms-title.html.

Sensory Characteristics

Do not reference content solely by color, shape, size, sound, or location. Note: “above” and “below”
references are acceptable to discuss content before and after a point in the content when presented in
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logical order. Avoid statements like, “press the green button to continue,” “refer to the list to the right,”
“the top-left image shows...,” etc.

Use of Color

Color alone cannot convey information. This criterion applies to all content, including text, links, and
non-text content.

Text and Links

Where the font color changes or is highlighted for a reason (e.g., a color-coded table, “the green text are
updates,” “
uniquely, visually convey this information without color. This includes linked words among other text.
See further discussion on links under “Color Contrast.”

red form fields are required,” “see the highlighted information”), provide another way to

Non-text Content

Non-text content includes items such as graphs, charts, and figures. Ensure any information conveyed by
a color change is conveyed in another way to uniquely, visually convey this information without color.
For line graphs, provide a unique marker, line style, or a descriptor pointing to each line. For charts,
provide a unique pattern on each segment or the category label of each segment near the segment.
Adding the values of a point on a line or segment does not satisfy this criterion.

Color Contrast

All text color combinations must meet WCAG 2.0 AA minimum color contrast requirements. Large text
(i.e., 14 pt bolded and larger or 18 pt nonbolded and larger) must have a minimum color contrast of 3:1.
Text not meeting the minimum font size for large text must have a minimum color contrast of 4.5:1.
Minimum color contrast requirements apply to text—background combinations (e.g., black text on a
white background) and images of text where the image replaces the text to maintain a certain look such
as an infographic or flow chart.

The color contrast requirement does not apply to logos or where the text is incidental to a graphic.
Links

Minimum color contrast applies to linked words among other text where the only difference between
the linked words and surrounding text is color (e.g., the underline typically representing a link is
removed). In these cases, ensure minimum contrast of 3:1 or greater between the color of the linked
words and the color of the surrounding text. In addition, provide another visual indicator when tabbing
to or pointing to the link such as adding an underline or changing the font to bold. Link contrast
requirements are in addition to the contrast requirements of text against the background.

Several websites and tools are available to check color contrast, including the following:

e https://webaim.org/resources/contrastchecker.
e https://webaim.org/resources/linkcontrastchecker.
e https://developer.paciellogroup.com/color-contrast-checker/.
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References

e https://www.w3.0rg/TR/WCAG20-TECHS/G14.html.

e https://www.w3.0rg/TR/WCAG20-TECHS/G111.html.

e https://www.w3.0rg/TR/WCAG20-TECHS/G182.html.

e https://www.w3.0rg/TR/WCAG20-TECHS/G183.html.

e https://www.w3.0rg/TR/UNDERSTANDING-WCAG20/visual-audio-contrast-without-color.html.

e https://www.w3.0rg/TR/WCAG20-TECHS/G96.html.

e https://www.w3.0rg/TR/UNDERSTANDING-WCAG20/content-structure-separation-
understanding.html.

e https://www.w3.0rg/TR/WCAG20-TECHS/G145.html.

e https://www.w3.0rg/TR/UNDERSTANDING-WCAG20/visual-audio-contrast-contrast.html.

Text as Text
Render text as text, not images of text. Exceptions to this rule include the following:

e When text is essential to a graphic (e.g., logo, flowchart, infographic, equation).
o The image of text is visually customizable to meet the users need.

References

e https://www.w3.org/TR/UNDERSTANDING-WCAG20/visual-audio-contrast-text-
presentation.html.

Bookmarks
Bookmarks allow users to navigate a document by providing a hierarchal outline of the document.
Documents with more than nine pages require bookmarks. To ensure a document has bookmarks, open

the “Bookmarks” pane on the “Navigation” pane, as shown below. Confirm the bookmarks are accurate
and are representative of the document structure. Rearrange and nest bookmarks as needed by
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selecting the bookmark and using the “Cut” and “Paste under/after Selected Bookmark” commands
found in the “Options” menu.
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Generate bookmarks as needed. Select the “Options” menu item in the “Bookmarks” pane and select
“New Bookmarks from Structure,” as shown below.

Select all the available headings, then select “OK.” The example document shown below has three
heading levels, (i.e., H1, H2, and H3) that are presented in the “Structure Elements” dialog box.

Structure Elements *
Structure
Artifact ~
Figure
Hi1
H2
H3
Inline5Shape
L
LBody w
Select All Clear All

Once the bookmarks are generated, ensure they are correctly nested. Rearrange bookmarks as needed
using the “Cut” and “Paste under/after Selected Bookmark” commands found in the “Options” menu.

References

e https://www.w3.org/TR/WCAG20-TECHS/PDF2.html.
e https://www.w3.org/TR/UNDERSTANDING-WCAG20/navigation-mechanisms-mult-loc.html.
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Page Numbering

Creating Section 508 Conformant PDFs

Ensure the page numbering found in the PDF viewer matches the page numbering in the document. As

shown below, the page number in the screen shot is

oa:n
|

as is the page number in the PDF viewer.

Files - Adobe Acrobat Pro DC
Plug-Ins Window Help

Creating Accessible.. *

Q ® @

Table of Contents,

Links .....

Movement.............
Language of Parts......
Text as Text

Text boxes

Background Information......
Logical Order........ccocevvveennee.
Graphics .oovvvveiiiieneins
Graphs and Charts.....

Equations

FHWA-HAD-20-001

September, 2020

To change the page number displayed in the PDF viewer, navigate to the “Page Thumbnails” pane in the
“Navigation” pane. Select the page(s) to be renumbered then select “Page Labels” from the “Options”
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menu. In the “Page labels” dialog box, select “Begin new section” then set the “Style,” “Prefix,” and
“Start” as needed found under “Numbering” to match the number(s) in the document.

Page labels

() Selected
() From: |i To: i of 23

Mumbering

(@ Begin new section

Styler |0, i, iii, ... w

Prefi |

Start: |1

Extend numbering used in preceding section to selected pages

Sample: i, i, i, ..

QK Cancel

References

e https://www.w3.0rg/TR/WCAG20-TECHS/PDF17.html.

e http://www.w3.0rg/TR/2008/REC-WCAG20-20081211/#consistent-behavior-consistent-
locations.

e http://www.w3.0org/TR/2008/REC-WCAG20-20081211/#content-structure-separation-

programmatic.

Logical Tab Order

Specify the tab order for each document to ensure content is read in a meaningful and understandable
order. To do this, access the “Page Thumbnails” pane. Select all the pages by selecting one thumbnail
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and selecting Ctrl + A on the keyboard. Navigate to the “Page Thumbnails” “Options” menu and select
“Page Properties” as shown below.

In the “Tab Order” tab of the “Page Properties” dialog box, select “Use Document Structure,” and then
select “OK,” as shown below.

Page Properties x

Tab Order  Actions

(O) Use Row Order
(D) Use Column Order

(O Unspecified

Choose one of the above options to
set the order for tabbing through
iterns on a page.

References

e https://www.w3.org/TR/WCAG20-TECHS/PDF3.html
e https://www.w3.org/TR/UNDERSTANDING-WCAG20/content-structure-separation-

sequence.html.
e https://www.w3.org/TR/UNDERSTANDING-WCAG20/keyboard-operation-keyboard-

operable.html
e https://www.w3.org/TR/UNDERSTANDING-WCAG20/navigation-mechanisms-focus-order.html.

FHWA-HAD-21-001 January 2021, Updated June 2024 26


https://www.w3.org/TR/WCAG20-TECHS/PDF3.html
https://www.w3.org/TR/UNDERSTANDING-WCAG20/content-structure-separation-sequence.html
https://www.w3.org/TR/UNDERSTANDING-WCAG20/content-structure-separation-sequence.html
https://www.w3.org/TR/UNDERSTANDING-WCAG20/keyboard-operation-keyboard-operable.html
https://www.w3.org/TR/UNDERSTANDING-WCAG20/keyboard-operation-keyboard-operable.html
https://www.w3.org/TR/UNDERSTANDING-WCAG20/navigation-mechanisms-focus-order.html

Creating Section 508 Conformant PDFs

Tags
Tagging Meaningful Content

Confirm all content conveying meaningful information is tagged. Remove any tags for content not
conveying meaningful information using the steps in the “Deleting a Tag” section. Content not conveying
meaningful information includes:

e Blank/empty tags (except empty table data (TD) tags that are needed to keep the table
structure).

e Extra hard returns.

e Page numbers.

e Redundant content (e.g., repeating header and/or footer content is tagged once).

e Decorative or background images used only as design elements.

Content Order Within Tags

Confirm the content within each tag is in logical order, especially with tags containing links, footnotes,
endnotes, and object elements. The screen shot below shows a paragraph with various elements inside
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a paragraph tag out of logical order. The links for the footnotes and the second equation are not in
logical order because they appear after all the other content.

e Rearrange the content within the tags to be in logical reading order.
e Reading order also applies to tables with figures (e.g., images, equations, logos) in cells.
Commonly, figure tags are outside of table tags. Reorder any out-of-order elements using the

technique discussed above.
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Tag Order
Ensure tags are in logical reading order. Logical order is checked by inspecting the tags manually.

Check the tag order by expanding the tag tree and going through each tag one-by-one from the start of
the tag tree to the end. To highlight the content associated with each tag, select “Highlight content”
from the “Options” drop down in the “Tags” pane as shown below.

Untag Delete

Expand all Ctrl+Plus
Collapse all Ctrl+Minus
Cut Ctrl+X

Paste 3
Create tag 3
Cleanup 3

v Highlight content

Level up Ctrl+P

Level up children of tag Ctrl+Shift+P
Change tag order 3
Copy contents ... »

Place any out-of-order tags in their correct, logical reading order.

Logical reading order does not have to match identically the order in which content appears on a page.
For example, some prefer a figure caption reads before the figure itself. In this case, the caption tag is
moved before the figure tag, where in print the caption appears after the figure. Another example,
footnotes are placed at the bottom of a page in print, but the tags associated with each footnote
typically are placed directly after they are introduced in a paragraph, which reflects the logical order in
which content is read as opposed to the literal order as it appears on the page.

References

e https://www.w3.org/TR/UNDERSTANDING-WCAG20/content-structure-separation-
sequence.html.

Split Content

Be mindful of content spanning more than one page. In some cases, the content on the first page is
tagged separately from succeeding pages. As shown below, one paragraph spans two pages and is
tagged in two P tags instead of one. Merge the separate tags into one tag. Content spanning more than
one page is common for paragraphs, tables, tables of contents, and lists.
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To merge split content, expand the applicable tags. Move the content from all applicable tags into one
tag and ensure the content is in the proper reading order.

Semantically Correct Tag Usage

Tag all meaningful content in semantically correct tags. Become familiar with the standard PDF tags.
Inspect all tags to confirm they are used correctly (e.g., lists are tagged as lists and not paragraphs,
headings are properly defined and provide hierarchal structure to the document, etc.). Specific tags are
discussed in more detail in the following sections.

Some files may contain tags that are not a standard PDF tag. These tags are called “Nonstandard PDF
tags.” See the discussion on “Role maps” in the “Nonstandard PDF Tags” section for more information
on nonstandard PDF tags.

References

e https://www.w3.org/TR/WCAG20-TECHS/G115.html.
e https://www.w3.org/TR/UNDERSTANDING-WCAG20/content-structure-separation-
programmatic.html

Container Tags
Document tag

The “Document” tag is the main container tag. Nest all PDF tags under the “Document” tag so the tag
tree will appear as:

e Tags

0 <Document>
= {All tags}
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This is also shown in the screen shot below.

Other Container Tags

The following are other container tags used to group tags under the <Document> tag.

e Part.
e Art(icle).
e Sect(ion).

e Div(ision).

Use none, one, two, or all the above other container tags in a file, typically in the order listed, to
subdivide large content into semantically smaller sections. Use of container tags other than the
Document tag is not required. When used, use consistently (e.g., if a chapter is put in a container tag
such as a Part, all are put in their own Part container tag).

References

e https://www.pdfa.org/resource/tagged-pdf-best-practice-guide-syntax.
e https://helpx.adobe.com/acrobat/using/editing-document-structure-content-
tags.html#standard pdf tags.

Title

Tag the title and subtitle of a document, as applicable, as paragraph tags.
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Headings

Confirm all visual headings are tagged with heading tags, the headings are used in hierarchal order, and
the content within the heading is text. The main division, such as a chapter title, is tagged as H(eading)1.
The next major grouping under H1 is H2, and so on.

Heading tags H2—H6 are used as needed in descending order to structure the document. Do not skip a
heading level. Do not use the H tag (i.e., H with no number after it).

References

e https://www.w3.org/TR/WCAG20-TECHS/PDF9.html.

e https://www.w3.0rg/TR/UNDERSTANDING-WCAG20/content-structure-separation-
programmatic.html.

e https://www.w3.0rg/TR/UNDERSTANDING-WCAG20/navigation-mechanisms-descriptive.html.

Paragraph

One paragraph is contained in a single paragraph tag. If more than one paragraph is contained in a single
paragraph tag, extract the additional elements, and nest the content under a separate paragraph tag. Do
this as many times as necessary so every paragraph has its own paragraph tag.

Table of Contents

Confirm tags for tables of contents (i.e., table of contents, list of figures, and list of tables) are tagged
and nested correctly. Properly nested table of contents tags match the outline or heading structure of
the document.

Properly nested tables of contents are as follows:

e <TOC> This is the root (main) level under which all TOCI tags are nested.
0 <TOCI>This is level 1 (e.g., chapter 1 or a main heading).
0 <TOCI> This is another level 1 (e.g., chapter 2 or a main heading).
= <TOC> This is the entire table of contents for the subsections under the above level 1.
O <TOCI> This is the first subsection of level 1 (e.g., Chapter 2.1).
O <TOCI> This is the second subsection of level 1 (e.g., Chapter 2.2).
o ...
O <TOCI> This is level 1.
(0]

Every level of content in a table of contents is nested under its own TOC tag, i.e., each heading level is a
TOCI child tag nested under a TOC parent tag, which is the child of the previous TOCI tag.

Nest each table of contents item in a single TOCI. Each TOCI contains a Reference tag, a Link tag

(optional, use when the item is a link), the text of the TOCI, and a Link-OBJR (optional, use when the
item is a link). This information is nested as follows:
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e TOCI
0 Reference
= Link (optional, use when the item is a link)
o Text of the TOCI
e Link-OBIJR (optional, use when the item is a link)

When the Link tag is omitted, nest the text of the TOCI under the Reference tag.

The screen shot below shows the tag tree for the TOCI “Structure.” “Structure” is an H1 in the
document. “Structure” contains two subheadings, “Styles” and “Formatting” tagged as H2 in the
document. These two subheadings are further divided into subsections, “Style Use, “Headings,” etc.,
tagged as an H3 in the document. These items from the table of contents are tagged as described above
with TOCI, Reference, Link, Link-OBJR, and the text of the TOCI.

iles - Adobe Acrobat Pro (64-bit)
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References

e https://www.w3.org/TR/WCAG20-TECHS/G64.html.
e https://www.w3.org/TR/UNDERSTANDING-WCAG20/navigation-mechanisms-mult-loc.html.
e https://www.levelaccess.com/blog/pdf-table-of-contents/.
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Lists
Confirm all lists are tagged and nested correctly.

e <L>This is the root (main) level under which all LI tags are nested.
e <LI>This is a list item containing all list elements, including the label and list body.
0 <Lbl>This is the list label containing the bullet point or ordered-list number/letter. Use of
the Lbl tag is optional. In the rare case a bullet does not convert to the correct symbol in a
PDF, it can be placed in an Lbl tag to remediate. Do not put alt or actual text on the Lbl.
0 <LBody> This is the list body containing all the content of a bullet item. If other elements
(e.g., paragraphs, tables, images, properly tagged sublists) appear between items in a list,
nest them under this tag.

Be mindful of lists breaking over pages. They may be tagged as multiple L tags or content incorrectly
tagged.

Tag each list in only one L tag. Tag each bullet item in only one LI tag. For example, a list of five items is
tagged as discussed above in the screen shot below.

Fs
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The screen shot below shows the tags for a list of seven items, the first of which contains a sublist of
four items. The parent L tag has seven LI tags. The first LI tag has a nested LBody tag. Nested in the
LBody is the text of the bullet, an L tag, and the nested LI tags for the sublist of four items.

The screen shot below shows a common issue of lists containing sublists and other elements, such as
paragraphs, figures, and tables. This list is a list of three items. The first bullet contains a sublist of two
items, the second bullet contains a paragraph, and the third bullet has the bullet text only.

As shown in the screen shot below, this is tagged incorrectly as a list of two items, a paragraph, then a
list of one item.
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Tag this correctly as a list of three items as shown below by moving the LI tag for the third bullet to be
the third LI under the first L tag. Delete the now empty, second L tag.
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Next, nest the P tag for the paragraph in the LBody for the second list item. The sublist of two items was
correctly tagged originally as a list two items nested in the LBody of the first list item as shown below.

References

e https://www.w3.org/TR/WCAG20-TECHS/PDF21.html.

Tables
Properly tag tables.

Do not add alt text to tables.

If a table breaks over two or more pages, ensure column header rows for the second and subsequent
pages are untagged. Tag as one table without regard to the page breaks.
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Properly structure tables are tagged as follows:

e <Table> This is the root (main) level under which all TR tags are nested.
0 <TR>This is the table row tag, which defines all cells in a horizontal row. <TR> is a child of
<Table>.
= <TH> This is the table header tag, which defines table cells that are column or row
headers. TH is a child of TR.
=  <TD> This is the table data tag, which define table cells that contains data. TD is a child
of TR.

Table Editor Initial Setup

A user needs to set up the “Table Editor” options in the “Reading Order” tool once; the settings will
remain each time a new PDF is opened. In the “Reading Order” tool under the “Options” menu, confirm
the following are checked:

e “Show page content groups” and “Page content order.”
e “Show table cells.”
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o “Display like elements in a single block.”
e  “Show tables and figures.”

FHWA-HAD-21-001

Reading Order

Draw a rectangle around the centent then click one of

the buttons below: EEJ
Text/Paragraph Figure
Form Field Figure/Caption
Heading 1 Heading 4 Table
Heading 2 Heading 5 Cell
Heading 3 Heading & Formula
Reference (g) Mote (z) Background/Artifact
Table Editor
Show page content groups ||

(O] Page content order

() Structure types

[+ Show table cells ]

[] Display like elements in a single block

[ Show tables and figures | ]
Clear Page Structure... Show Order Panel
Help Close
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Navigate to a table tag in the “Tags” pane and select “Table Editor” from the “Options” menu. When the
“Table Editor” is selected, the table is highlighted.

Continue to set up the “Table Editor” by selecting the context menu of a cell by right clicking on it or

selecting Shift + F10 then select “Table Editor Options...”

|  stat~
flabama

Arizona

hlaska

Nrkansas

! Fate I Rabbits
Table Cell Properties... 6064 3167
_ _ 9410 4003
Table Editor Options... 16930 1075
467 131
Auto Generate Header Cell 1Ds

FHWA-HAD-21-001
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Under the “Label Option” section, confirm “Show cell type (TH or TD)” is checked.

With this setting checked, the table header (TH) and table data (TD) cells are identified.

Simple Table
TH| State | ITHl cCats TH| Dogs TH|Rabbits
Hjama D 7101 D s064 | |l 3167
Hpna in 9030 in 9410 in 4003
Hlia D 13009 m 16380 | k)l 1075
Hinsas in 267 TDH 457 in 131

Table Remediation

For all tables, confirm all column and row headers are tagged as TH with their appropriate scope, there
are no blank column or row headers, and all data cells are tagged as TD.

The screen shot below shows a table where the row headers are identified as TD instead of a TH.

Simple Table
| JTH state [FHl cats TH| Dogs TH[ Rabbits
 [TDbama | [TD 7101 D 6064 | [tD 3167
TDlona D 9030 TD 9410 D 4003
TDska D 19009 D 16980 D 1075
TDjansas TD 267 TD 467 TD 131
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To changea THto a TD or a TD to a TH, navigate to the cell and select “Table Cell Properties...” from the
context menu.

Simple Table
[TH| state [lTHl  cats TH| Dogs TH| Rabbits
Tnbama [ o 7101 ins 6064 | |TD 3167
Table Cell Properties... e 1D Lt
16980 TD 1075
Table Editor Options... A67 D 131
Auto Generate Header Cell [Ds % Table #1
T — : wremestic [ Wil

In the “Table Cell Properties” under the “Type” section, select “Header Cell” to change the cell to a TH.
Select “Data Cell” to change the cell to a TD.

Table Cell Properties *

Type
() Header Cell Scope: | None
@®Data Cell

Attributes
Row Span: I'I
Column Span: |1

ID: |

Associated Header Cell IDs: o
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For all TH cells, identify the “Scope.” The “Scope” specifies if the TH is a header for a column “Scope:
Column” or a header for a row “Scope: Row.” The “Scope” is found in the “Type” section of the “Table

Cell Properties” dialog box. It becomes active when “Header Cell” is selected.

Table Cell Properties

Type
(®) Header Cell Scope;

(Z) Data Cell

Attributes

Bow Span:
Column Span:
1D:

Associated Header Cell IDs:

Maone

Row
Column
Both

_

i

Cancel

Select “OK” when edits are completed.

Simple Tables

Below is an example of a simple table. A simple table is one that has one level of column and/or one
level of row headers and no cells that span multiple rows and/or columns. In the screen shot below, the
column headers are the first row of cells; “State,” “Cats,” “Dogs,” and “Rabbits.” The row headers are
the cells in the first column, excluding the first cell in the first row which is the column header “State.” In

this case, the row headers are “Alabama,

” “Arizona,” “Alaska,” and “Arkansas.”

~

State Cats Dogs Rabbits
Alabama 7101 6064 3167
Arizona 9030 9410 4003
Alaska 19009 16980 1075
Arkansas 267 467 131

»
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Inspect each table to identify row and column headers. Ensure each column header is identified with a
TH tag and the “Scope” is “Column.” Ensure each row header is identified with a TH and the “Scope” is
“Row.” For each TH with the “Scope” of “Column,” ensure all the data in a column is associated with its
header. Do the same for TH with the “Scope” of “Row.” Ensure all the data in a row is associated with its
header. In the screen shot below, all TH tags are identified for the sample simple table.

Simple Table
TH State TH] Cats TH Dogs TH Rabbits
THibama TD 7101 TD 6064 TD 3167
THizona TD 9030 TD 9410 TD 4003
THiska 1D 19009 TD 16980 TD 1075
THtansas TD)| 267 1D 467 1D 131

Complex Tables

Complex tables have more than one header row for each column header, and/or vice versa, and often
have merged cells. Below is an example of a complex table. It has two levels of column headers:
“Location” spanning two columns, then under “Location” are the headers “State” and “County” for
example.

It has two levels of row headers. For example, under the column header “Location” and “State” is the
row header “Alabama” which spans two rows. Under “Location” and “County” for the row header
“Alabama” are the row headers “Baldwin” and “Bibb.”

Location Domestic Wwild
State County Cats Dogs Rabbits Bears Deer Moose
Alabama Baldwin 7101 6064 3167 654 91096 30654
Bibb 6735 367 47 7473 36346 63456
Alaska Anchorage 19009 16980 1075 1970 9838 14179
Juneau 634 8585 86 4266 13984 36546
Sitka 6864 4782 9456 8457 6798 26747
Arizona Gila 9030 9410 4003 3712 6700 60
Maricopa 8252 732 3077 37834 3796 21656
Pima 7356 634 963 23255 346346 2523
Arkansas Ashley 267 467 131 5764 585 897
Boone 9672 7832 5633 6155 2323 2622
Clay 1534 6416 1259 1145 736 63623

Use “Scope” to markup complex tables when everything in the column or row is associated with its
header as discussed in the “Simple Table” section. For example, all the data in the columns under
“Domestic” is related to that header and all the data in the rows for “Alabama” are related to that
header. Set the TH for each column and row header along with its scope, as discussed above. Adjust
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each cell spanning more than one row or column by typing the appropriate values into the “Row Span”
and/or “Column Span” fields in the “Attributes” section of the “Table Cell Properties” dialog box.

Shown above is the “Table Cell Properties” for the cell “Location” in the table. The default shows the
“Column Span” is set to “1.” Update that field to match the actual number of columns the cell is
spanning, 2 as shown below.

If a column or row contains data not associated with its header, it is a complex table needing “Headers”
and “ID” to make the associations between the data cell and its headers. The screen shot below shows
an alternate format of the complex table example. The row headers of “Alabama,” “Alaska,” “Arizona,”
and “Arkansas” are in a separate row with merged cells spanning all columns. The county rows for each
state follow. This layout separates the data visually. In this case, all the cells in a column are not
associated with the column headers (e.g., “Alabama” is not data for “Domestic” “Dogs”). Also, reading
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across a row beginning with the counties, the states are missing. “Scope” cannot be used. “Headers” and
“ID” are needed to make the associations between data cell and its headers. Adding “Headers” and “ID”
to the TH and TD cells is beyond the scope of this documentation.

Complex Table #2
Location Domestic Wild
Cats Dogs | Rabbits Bears Deer Moose
Alabama
Baldwin 7101 6064 3167 654 91096 30654
Bibb 6735 367 47 7473 36346 63456
Alaska
Anchorage 19009 16980 1075 1970 9838 14179
Juneau 634 8585 86 4266 13984 36546
Sitka 6864 4782 9456 8457 6798 26747
Arizona
Gila 9030 9410 4003 3712 6700 60
Maricopa 8252 732 3077 37834 3796 21656
Pima 7356 634 963 23255 346346 2523
Arkansas
Ashley 267 167 131 5764 585 897
Boone 9672 7832 5633 6155 2323 2622
Clay 1534 6416 1259 1145 736 63623

Irregular Tables

The tables in the examples above are regular tables. Each row has the same number of columns, and
each column has the same number of rows, including row and column spans. Irregular tables have cells
missing in row(s) or column(s). Avoid irregular tables. An example of an irregular table is shown below
since the first cell in the first row is missing. Remediating such tables is beyond the scope of this
documentation.

Cats Dogs Rabbhits
Alabama 7101 6064 3167
Arizona 8030 5410 4003
Alaska 15009 16980 1075
Arkansas 2687 467 131
Layout Tables

When tables are used for layout, remove the table structure tags as discussed in the “Working with
Tags” section, leaving only the properly tagged content. The screenshots below show a form using a
table for layout. In the first screen shot, the content is tagged as a table. The second screen shot shows
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the same content after removing the table tags, leaving the P tags. While both tables appear visually
identical, they have different tag structure.
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Artifacts

The outlines of cells in a table are artifacts. While cells on the page are outlined visually, it is
unnecessary to have their artifacts in the table tag tree. To remove artifact tags, expand the tag tree
under the table tag. Navigate to the artifact tag and delete by selecting “Delete Tag” from the “Options”
menu.

References

e https://www.w3.0rg/TR/WCAG20-TECHS/PDF6.html.
e https://www.w3.0rg/TR/WCAG20-TECHS/PDF20.html.
e https://www.w3.0rg/TR/WCAG20-TECHS/H51.html.

e https://www.w3.0rg/TR/WCAG20-TECHS/H43.html.

e https://www.w3.0rg/TR/WCAG20-TECHS/H63.html.
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Figures

Non-text content includes, but is not limited to, images, figures, and equations. Typically, these are
tagged in a Figure tag.

Alternate Text

All non-text content conveying information needs “Alternate Text,” also known as “alt text,” which is a
description stating the meaning of that content. To check the alternate text of the non-text content, go
to “Properties” on the “Options” menu for the tag. Alternate text is entered in the fourth field,
“Alternate Text for Images,” under the “Tag” tab of the “Object Properties” dialog box, as shown in the
screen shot below.

Content Tag Color

Bpe |G /]
Title: |
Actual Text: |

FHWA Section 302, You are the key,

Alternate Text for Images:

ID: |

Language: | "

Edit Tag... Edit Attribute Objects... Edit Attribute Classes...

Close

If the non-text content is redundant (e.g., a logo repeated on the front and back cover), tag it once and
include the appropriate alternate text. Set any redundant non-text content or non-text content not
conveying information as decorative (i.e., remove the tag).
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Best practices for alternate text include the following:

e Confirm the alternate text does not repeat the caption or surrounding text or contain
information not in the non-text content.

e Do not start alternate text with wording like “This is an image of...,” “This is a photo of...,” etc.

e Use alternate text to describe the non-text content in a level of detail matching the level of
detail the figure is conveying in context.

e Alternative text needs to describe the meaning, not the look. For example, “The road test
segment started at the intersection of Main and First streets and continued 1-mile to the
intersection of Main and Fifth street” vs “The road test segment is highlighted in blue with red
arrows pointing to the starting and ending locations.”

0 Remove the image an replace with words to keep the same meaning in the document.
Those words are the alternative text.

e Be concise and describe the purpose in as few words as possible.

e If an acronym or abbreviation is already defined, put the acronym or abbreviation in the
alternative text, it does not need to be redefined. Do not add spaces between the letters of an
acronym or abbreviation.

e When one graphic is tagged with multiple Figure tags, e.g., arrows were inserted onto an image
to point out a location, merge them into a single Figure tag. Add the alternate text to the single
Figure tag.

e Complex graphics, like a flow chart, can be broken up into smaller images and tag each in a
Figure with its own alternative text.

Actual Text

Use Actual text on the rare occasion where text is a graphic (e.g., text not recognized in a scanned
document). Do not use both actual text and alternate text in the same tag.

Equations and Symbols

How equations and symbols are tagged in a PDF varies widely and depends on how they are entered in
the source document, the software version of the source document, and how the PDF is created.
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If the equation or symbol is correct as text (i.e., the proper Unicode symbol was used for each symbol)
and in the proper reading order within the tag, as shown below, no further remediation is needed.

To find the equation or symbol within the tags, navigate to the “Content” pane of the “Navigation”

pane. Use the same instructions as “Finding a Tag” except select “Find Content from Selection” on the
“Options” menu.

If the equation is non-text (e.g., tagged as a <Figure>), ensure it is in the proper reading order within the

tag. As discussed previously, some content within a tag can be out of order which is especially true for
non-text equations and symbols. In the screen shot below, the figure tag for the equation a + b = ciis out
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of order since it is the last item nested under the paragraph tag. To fix this, select the figure tag and
move it to the correct location as discussed in the “Moving a Tag” section.

After the proper reading order is determined, confirm the alternate or actual text for the equation is
correct. Appropriate alternate text for an equation is a verbal representation of the elements making up
the equation. Do not add extra information or explanations, such as definitions of variables or qualifying
statements. For the equation a + b = ¢, the alternate text reads “a plus b equals c.” Do not define the
variables in the alternate text. Ensure the case of the symbols in alternate text is correct (e.g., the
alternate or actual text for “y” is “gamma”, the alternate or actual text for “I"” is “Gamma.”) Using the
wrong case for symbols can change the meaning of an equation. When a lowercase symbol (i.e., a letter
from the English alphabet or a spelled-out Greek symbol) starts the alternate or actual text, do not
capitalize it.

If an equation or symbol is text and the proper Unicode symbol was not used in the source document,

the symbols may not carry over when converted to PDF. Sometimes, symbols are replaced with an
empty box or another incorrect character.
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As shown below the i symbol does not display in the “Content” pane of the “Navigation” pane.
Although it visually appears correct in the “Document” Pane, a screen reader or other assistive
technology will read this as “square root of two” instead of “square root of pi divided by two.”

Document Pane

To correct an issue like the symbol not displaying correctly, highlight the content. On the “Tags” pane
navigate to the “Options” menu and select “ New Tag.”
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A “New Tag” dialog box will pop up. Select “Span” from the “Type” dropdown.

Mew Tag *
Type: v
Title: |

OK Cancel

Move the span tag to the correct reading order and move the content that did not convert into the new
tag as discussed in the “Working with Tags” section. Add alternate or actual text as previously discussed.

References

e https://www.w3.0rg/TR/WCAG20-TECHS/PDF1.html.

e  https://www.w3.0rg/TR/UNDERSTANDING-WCAG20/text-equiv-all.html.

e https://www.w3.0rg/TR/UNDERSTANDING-WCAG20/visual-audio-contrast-text-
presentation.html.

Caption

Tag table and figure titles in caption tags. Limit content in the caption tag to the text that describes the
table or figure. Do not include other content, such as an image source. Do not nest caption tags under

the parent table or figure tag. Instead, place captions at the same hierarchy level as the table or figure

tags in the tag tree. Captions can come before or after their respective tables or figures, depending on

the style of the document and the reading order in which they are placed.

References

e https://www.w3.org/TR/WCAG20-TECHS/H39.html.
e https://helpx.adobe.com/acrobat/using/editing-document-structure-content-tags.html.

Links

Ensure the text color of links meet contrast requirements as needed.
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Nested under the link tag are the words in the document associated with the link and a Link-OBIJR, as
shown in the screen shot below.

If no Link-OBJR is present, add it. Navigate to the link tag missing the Link-OBJR, then from the “Tags”
pane “Options” menu, select “Find.” Then, from the “Find Element” dialog box, select “Unmarked Links
from the “Find” dropdown menu, as shown below. Then, select “Find” and then select “Tag Element.”
The Link-OBJR is then nested under the appropriate link tag. Repeat as necessary by page or for the
entire document by selecting the “Search Page” or “Search Document” radio buttons, respectively.

”

Ensure one link tag is used per link. When a link spans two or more lines, each line may be tagged
separately. When one link is tagged in two or more link tags, merge the link tags by moving the
elements from under the extra link tags to the first link tag in proper reading order. Each line the link
spans can contain one Link-OBJR, for example, a link spanning two lines can contain two Link-OBJRs.
Remove the empty, extra link tags.

Avoid nesting figures under link tags. When a figure is nested in a link, ensure the description of the
image is the same as the link destination.

Alternate text is not needed for links where the text nested in the link tag is descriptive of the link
location, destination, or purpose. While ambiguous or repetitive links, e.g., “Click here for more
information” should be avoided in the source, if they are included in the PDF, add alternate text to
describe the destination, function, or purpose of the link. Include alternate text on link tags containing
only a nested figure tag without nested text.

References

e https://www.w3.org/TR/WCAG20-TECHS/PDF11.html.
e https://www.w3.org/TR/WCAG20-TECHS/PDF13.html.
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e https://www.w3.org/TR/UNDERSTANDING-WCAG20/keyboard-operation-keyboard-

operable.html.
e https://www.w3.org/TR/UNDERSTANDING-WCAG20/navigation-mechanisms-refs.html.

Acronyms and Abbreviations

Acronyms and abbreviations do not need alternate text. When using acronyms and abbreviations in
alternate text, do not add spaces between the letters (e.g., use FHWA, not FH W A).

Footnotes and Endnotes

Tag footnotes and endnotes using Reference and Note tags. The cross-reference in the body text is
nested in a reference tag, while the footnote/endnote itself is nested in a note tag.

Do not tag something as a Note because it says “note” in the text. Similarly, do not tag something as a
reference because it provides additional information about a topic. See the “Semantically Correct Tag
Usage” section.

There is no standard placement for the Note tag as long as it is in logical reading order. Place the note
tag directly after the parent tag containing the footnote/endnote, e.g., a P tag with the footnote in a
nested note tag, immediately following the Reference tag, or in the case of endnotes, at the end of the
document. Do what makes sense for the content, which is usually the former. Wherever the note tag is
placed, do so consistently throughout the document.

Header/Footer/Watermark Content

Do not tag page numbers. Untag/delete any tagged page numbers. Tag any meaningful header, footer,
and watermark content, aside from page numbers, such as “Draft,” publication date, etc., not tagged in
the body of the document, once. Do not tag every use on every page.

Nonstandard PDF Tags

Ensure nonstandard tags are mapped to the correct PDF tag in the “Role Map” so they are semantically
correct.

To access the “Role Map” select “Edit Role Map” from the “Tags” “Options” menu. In the “Role Map”
dialog box, expand “Document Roles” as shown in the screen shot below. Word objects such as an
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or other assistive technology will treat them like a figure.

Role Map

Path:

Type:

Document Roles\Annotation

MName

= Document Roles

/Annotation  /Span

/Artifact /P
/Bibliography  /BibEntry
/Chart  /Figure
/Diagram  /Figure
/DropCap  /Figure
JEndnote  /Mote
/Footnote  /Note
/InlineShape  /Figure
/Outline  /Span
/Strikeout  /Span
/Subscript  /Span
/Superscript  /Span
/TextBox  fArt
/Underline  /Span

i Lhange Item ] ’ Delete tem MNew Itemn

/My Changes to a role affect all elements referencing the role.

OK

| [ canea
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If any tag is incorrectly mapped, highlight it, and select “Change Item” from the “Role Map” dialog box
Then, type the correct value into the Value field on the “Change Value” dialog box, as shown in the
screen shot below.

Language of Parts

When using a word or phrase from a language different from the default human language of the
document, confirm the language of the word or phrase is tagged as the correct human language. To
change the language for an entire tag, navigate to the tag and select “Properties” from the “Tags” pane
on the “Options” menu. In the “Object Properties” dialog box, under the “Tag” tab, select the
appropriate language in the “Language” dropdown menu.

If only some of the content in a tag needs the default language changed, insert a span tag and nest the
content in the different language in this span tag. Change the language on the span tag as discussed
above.

References

e https://www.w3.org/TR/WCAG20-TECHS/PDF19.html.
e https://www.w3.org/TR/UNDERSTANDING-WCAG20/meaning-other-lang-id.html.

General Tag References

e https://www.w3.0rg/TR/WCAG20-TECHS/G115.html.

e https://www.w3.0rg/TR/UNDERSTANDING-WCAG20/content-structure-separation-
programmatic.html.

e https://www.pdfa.org/resource/tagged-pdf-best-practice-guide-syntax.

e https://helpx.adobe.com/acrobat/using/editing-document-structure-content-tags.html.
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Flashing
Ensure the document is free from any blinking or flashing content.
References

e https://www.w3.org/TR/UNDERSTANDING-WCAG20/seizure-does-not-violate.html.
e https://www.w3.org/TR/UNDERSTANDING-WCAG20/seizure-three-times.html.

Zoom

Except for images of text (if included) and captions, ensure all content is readable when zoomed to 200
percent.

References

e https://www.w3.org/TR/WCAG20-TECHS/G179.html.
e https://www.w3.org/TR/UNDERSTANDING-WCAG20/visual-audio-contrast-scale.html.

Optical Character Recognition (OCR)

If a document was scanned and converted to text using an optical character recognition (OCR), ensure
the content is recognized correctly. To correct, go to the tag with the error and select “Copy Contents to
Clipboard” from the “Tags” pane on the “Options” menu. Return to the same tag. Select “Properties”
from the “Tags” pane on the “Options” menu. Paste into “Actual Text” and correct the errors.

References

e https://www.w3.org/TR/WCAG20-TECHS/PDF7.html.
e https://www.w3.org/TR/UNDERSTANDING-WCAG20/visual-audio-contrast-text-
presentation.html.

Validators

A variety of accessibility validators are available. Some are for Section 508, while others are for different
accessibility requirements. Any validator finds less than 40 percent of Section 508 problems in a
document, so a clean validator report does not mean the document is Section 508 conformant.
Validators are good at some things, like determining if a figure has alternate text. However, they cannot
tell if the figure has appropriate alternate text. While validator results provide a good baseline of Section

508 conformance and often point out items requiring additional remediation, the majority of validating
for Section 508 conformance requires manual checks.

Forms

Forms and form-fillable fields are beyond the scope of this discussion.
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